Back to overview
Downtime
Network Issue for Coly Titan
Jun 28, 2024 at 3:08pm UTC
Affected services
Coly Titan
Resolved
Jun 28, 2024 at 3:35pm UTC
Network issue resolved. Coly Titan is now available again.
Affected services
Created
Jun 28, 2024 at 3:08pm UTC
Currently Coly Titan has no network. The issue has been acknowledge by our upstream provider.
Affected services